Mount-Fehler (5): Eingabe- / Ausgabefehler beim Mount


9

Ich erhalte einen Mount-Fehler (5):

Eingabe Ausgabefehler beim Mounten an cifs Windows Share.

Befehl ausgeführt:

sudo /bin/mount -t cifs //server/folder /mnt/folder/ -o username="domain/username",password=password

Fehler zurückgegeben:

Mount-Fehler (5): Eingabe- / Ausgabefehler Siehe Handbuch mount.cifs (8) (z. B. man mount.cifs)

Der Befehl ams funktionierte auf RHEL 32.


Bitte beziehen Sie sich auf den folgenden Link und folgen Sie SEC askubuntu.com/questions/491297/permanent-windows-share-mounting
— vembutech

Immer noch den gleichen Fehler nach dem Hinzufügen von sec = ntlm
— Abdul Jaleel

Antworten:


17

Beim Einrichten einer Freigabe auf einem Windows 2012-Server musste ich Folgendes verwenden:

sudo mount.cifs //server/folder /path/to/folder/ -o user=username,password=pass,vers=3.0

Beachten Sie die vers=3.0.

Basierend auf den folgenden Vorschlägen müssen Sie möglicherweise versuchen vers=2.0. Der versParameter ist der Schlüssel.


3
Vielen Dank. vers=2.0war definitiv der Schlüssel für mich bei der Montage, wie es bei der -m SMB2Auflistung von Aktien mit smbclient -L( client max protocol = SMB2in smb.conf, für permanente Einstellung) der Fall war .

Durch Hinzufügen von <code> vers = 2.0 </ code> zu den Optionen wurde unser Problem mit diesem Fehler behoben. Danke für den Vorschlag!
— Kentgrav

1
Diese Antwort hat bei mir unter Linux mit dem mountBefehl funktioniert . Ich hatte den mountBefehl versüber 2 Jahre ohne die Option verwendet und dann funktionierte die Montage plötzlich nicht mehr - obwohl ich mich mit dem Terminal verbinden konnte smbclient. Anscheinend hat sich irgendwo die Softwareversion geändert, so dass jetzt die vers=3.0Option benötigt wird, damit das Remote-Laufwerk gemountet wird.
— Geliebt.von.Jesus

Meins arbeitete mit vers = 2.1, sudo mount -t cifs -o username=myUser,password=myPassword,vers=2.1 //1.2.3.4/folderA/folderB /foo/bar --verbosewas seltsam ist, weil die Version 2.23 auf meiner Amazon Linux 1 EC2-Instanz[ec2-user@ip-1-2-3-4 ~]$ sudo mount --version mount from util-linux 2.23.2 (libmount 2.23.0: selinux, debug, assert)
— Kyle Bridenstine

1
vers = 2.0 war auch für mich die Lösung.
— YoMismo

2

Für mich war das Problem ein anderes, als ich versuchte, eine Freigabe von einem NAS-Gerät von einem neueren GNU / Linux-Desktop bereitzustellen. Die Angabe -o nounixzum Deaktivieren von Unix-Erweiterungen hat bei mir funktioniert.

Am Ende half es mir, in die Ausgabe zu schauen, dmesgdie mir sagte:

[160169.609325] CIFS VFS: Send error in SETFSUnixInfo = -5
[160169.609327] CIFS VFS: Negotiating Unix capabilities with the server failed. Consider mounting with the Unix Extensions disabled if problems are found by specifying the nounix mount option.
[160169.620877] CIFS VFS: Malformed FILE_UNIX_BASIC_INFO response. Unix Extensions can be disabled on mount by specifying the nosfu mount option.
[160169.620888] CIFS VFS: cifs_read_super: get root inode failed

2

Überprüfen Sie, ob das Domain-Konto nicht gesperrt ist


1
Bingo! Nach viel Frust error(5)kam mir der Gedanke, dmesgauf der GNU / Linux-Seite nachzuschauen, nur um zu finden Status code returned 0xc0000234 STATUS_ACCOUNT_LOCKED_OUT. Also habe ich die Eigenschaften des betreffenden Kontos überprüft, bei dem es sich um ein lokales Windows 10-Konto handelt, und es wurde sicher genug Account is locked outüberprüft. (Dies ist wahrscheinlich auf zu viele fehlgeschlagene Anmeldungen zurückzuführen, als ich früher an der Gesamtkonfiguration der Freigabe
— Ben Johnson

Ich glaube, ich hatte den gleichen Top-Level-Fehler, habe ihn gelöst, aber diese Frage in meiner Forschung so lange zurückgespielt, dass ich sie posten konnte. :)
— Paul
Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.