mount.cifs-Fehler (2): Keine solche Datei oder kein solches Verzeichnis bei Verwendung eines Präfixpfads


11

Ich habe diesen Befehl ausprobiert:

mount -t cifs //server/share/directory /mnt/directory -o credentials=/path/to/cifs.credentials --verbose

Antwort ist:

mount.cifs kernel mount options: ip=<IP of server>,unc=\\server \share,user=<username>,prefixpath=directory,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Wenn ich jedoch denselben Befehl ohne den Präfixpfad versuche:

mount -t cifs //server/share /mnt/directory -o credentials=/path/to/cifs.credentials --verbose

Es funktioniert und ich kann auf / mnt / directory / directory zugreifen.

Ich erhalte den gleichen Fehler, wenn ich den Präfixpfad in den Optionen explizit spezifiziere, dh:

mount -t cifs //server/share /mnt/directory -o credentials=/path/to/cifs.credentials,prefixpath=directory --verbose

Zusätzliche Information:

  • Ich kann mich mit dem gewünschten Pfad verbinden smbclient //server/share -U username -W domain -D directory
  • mount.cifs Version: 5.5
  • Debian-Kernel 3.2.0-4-amd64
  • Ich kann mit mount.cifs Version 4.5 auf dem Debian-Kernel 2.6.32-5-amd64 eine Verbindung zu einem anderen Computer herstellen

Irgendwelche Ideen, warum der Präfixpfad ein Problem zu verursachen scheint? Der gleiche Weg hatte in letzter Zeit funktioniert; Ich vermute, dass ein Update für ein Paket auf der Linux-Seite oder ein Windows-Update hinter dem neuen Verhalten steckt.


Ist das zu einem NAS? Wenn Sie sagen, Sie versuchen "ohne Präfixpfad", sieht der Befehl gleich aus. Ist das ein Tippfehler?
— Octopus

Es geht um ein NetApp SAN. Du hast recht, das war ein Tippfehler - ich habe es korrigiert.
— cherdt

Ein NetApp-Supporttechniker musste eine Paketverfolgung bereitstellen, in der festgestellt wurde, dass mount.cifs das Verzeichnis // server / share // anstelle von // server / share / directory sendet. Dies scheint die Ursache des Problems zu sein (obwohl keine Lösung).
— cherdt

Antworten:


6

Endlich eine Problemumgehung für dieses Problem gefunden, die mit unserer NetApp funktioniert. Wenn Sie kein DFS benötigen, versuchen Sie es mit der nodfsOption.

mount -t cifs //server/share/directory /mnt/directory -ocredentials=/path/to/cifs.credentials,nodfs

Wir verwenden auch netapp. Vielen Dank für diese Problemumgehung, die meinen Nachmittag gerettet hat.
— Danduk82
Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.