Sudo funktioniert nicht: "/ etc / sudoers gehört uid 1000, sollte 0 sein"


21

Wenn Sie den Befehl sudo über das Terminal eingeben, wird der Fehler angezeigt

sudo: /etc/sudoers is owned by uid 1000, should be 0
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

Antworten:


31

Ändern Sie den Besitzer wieder in root:

pkexec chown root:root /etc/sudoers /etc/sudoers.d -R

Oder verwenden Sie den visudoBefehl, um die allgemeine Korrektheit der Dateien sicherzustellen (danke an @KasiyA ):

pkexec visudo

3
Einfachere Möglichkeit zur Behebung ist:pkexec visudo
— αғsнιη

Ich habe ein Problem, ich habe eine ec2-Instanz und ich habe Ihre Lösung ausprobiert und es fragt nach einem Passwort. Wie mildere ich das?
— David

Nun, das ist scheiße. "Das Programm 'pkexec' ist derzeit nicht installiert. Sie können es installieren, indem Sie Folgendes eingeben: sudo apt-get install policykit-1"
— Koen.

@Koen. Es wird standardmäßig unter Ubuntu installiert (es sei denn, Sie sprechen von einem Server oder einer Minimalinstallation).
— muru

In der Tat eine Server-Installation, aber ich habe es behoben, indem ich im Einzelbenutzermodus gebootet habe.
— Koen.
Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.