FEHLER 1045 (28000): Zugriff für Benutzer 'root @ localhost' verweigert (mit Passwort: nein)


47

Ich versuche, die queXS cati-App auf meinem Ubuntu-Desktop zu installieren, habe MySQL-Server und PHP 5 installiert und kann mich ohne Passwort nicht als root am MySQL-Server anmelden:

mysql -u root 

es sagt

ERROR 1045(28000) : Access denied for user 'root@localhost' (using password: no )

Aber es ist okay, wenn ich eintrete mysql -u root -p

Ich kann nicht herausfinden, wo das Problem liegt.


7
Versuchen Sie

Antworten:


49

Hinzufügen eines Schalters -pfür die kennwortbasierte Anmeldung:

mysql -u root -p

Das ist das normale Verhalten. Sie haben ein Root-Passwort für Ihre Datenbank festgelegt, sodass Sie von nun an nicht mehr ohne Passwort darauf zugreifen können. Deshalb berichtet es:

Zugriff verweigert für Benutzer 'root @ localhost' ( mit Passwort: nein )

Es ist offensichtlich, dass -pSie Erfolg haben, wenn Sie das Passwort mit dem Schalter eingeben .


4

In einfachen Worten, Ihre "root" -Sitzung kennt kein Passwort für den mysql-root-Benutzer.

Wenn Sie den Zugriff auf Ihr MySQL vereinfachen möchten

erstelle .my.cnf in / root /

und rein damit

[mysqladmin]
 user = root
 password = mysqlrootpassword
[mysql]
 user = root
 password = mysqlrootpassword
[mysqldump]
 user = root
 password = mysqlrootpassword

Wobei offcourse mysqlrootpassword Ihr Passwort für das Root-Passwort von mysql ist. Wenn Sie mysql ausführen, wird dieses Passwort verwendet

Denken Sie an die Sicherheit dieser Datei - setzen Sie sichere Rechte, damit niemand auf Ihrem Server sie lesen kann!


1
Es ist schlecht, andere zu ermutigen, Root-Passwörter als Klartext auf die Festplatte zu schreiben. Durch Abzug verbreitet sich diese Eigenschaft der Bösartigkeit auf die Person, die sie tut.
— Eric Leschinski

Während der Installation wird das temporäre Passwort des mysql root-Benutzers festgelegt. sudo grep 'temporäres Passwort' /var/log/mysqld.log
— suyash

-1

Melden Sie sich bei webmin und unter Servern an, und greifen Sie auf den mySQL-Datenbankserver zu. Anschließend können Sie das (Benutzer-) Kennwort festlegen, sofern Sie über Folgendes verfügen:

mysql -u (**user**) -p < /usr/share/doc/rsyslog-mysql-5.8.10/createDB.sql.

Die Web-GUI ist einfach, aber um sicher zu sein, verwenden Sie das Terminal.

Prost.


existiert nicht /usr/share/doc/rsyslog-mysql-5.8.10/createDB.sql.
— Vitor Mazuco
Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.