MariaDB kann nicht installiert werden - Abhängigkeitsfehler?


8

Ich verwende Ubuntu 14.04 auf einer Digital Ocean VM. Ich versuche MariaDB 10.1 zu installieren. Dabei wird folgende Fehlermeldung angezeigt:

Setting up mariadb-server-10.1 (10.1.8+maria-1~trusty) ...
dpkg: error processing package mariadb-server-10.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mariadb-server:
 mariadb-server depends on mariadb-server-10.1 (= 10.1.8+maria-1~trusty); however:
  Package mariadb-server-10.1 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
     Errors were encountered while processing:
 mariadb-server-10.1
 mariadb-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Folgendes habe ich versucht, um dies zu beheben:

sudo apt-get remove --purge mysql-server mysql-client mysql-common
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get install mariadb-server

UND

Maschine neu starten

Ich habe eine Weile nach Stack Exchange und anderen Linux-Formularen gesucht und kann nicht herausfinden, was dies verursacht. Ich freue mich über jede Hilfe, die angeboten werden könnte!

UPDATE: Hier ist die Ausgabe von apt-get install -f:

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up mariadb-server-10.1 (10.1.8+maria-1~trusty) ...
dpkg: error processing package mariadb-server-10.1 (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of mariadb-server:
 mariadb-server depends on mariadb-server-10.1 (= 10.1.8+maria-1~trusty); however:
  Package mariadb-server-10.1 is not configured yet.

dpkg: error processing package mariadb-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mariadb-server-10.1
 mariadb-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Führen Sie sudo apt-get install -fdie Ausgabe aus und veröffentlichen Sie sie.
— Michael Hampton

@ MichaelHampton Ich habe die Informationen in die aktualisierte Frage eingefügt. Ich habe mir die Ausgabe schon einmal angesehen, sie ist nicht sehr nützlich.
— Zach Russell

Haben Sie jemals eine Lösung dafür gefunden?
— Jannej

Warum ist diese Frage hier noch bei Serverfehler oder nicht geschlossen?
— Rob

Antworten:


4

Gefunden im Protokoll:

[ERROR] /usr/sbin/mysqld: unknown variable log_slow_queries=/var/log/mysql/mysql-slow.log'

Also habe ich conf.d / local.cnf auskommentiert

#log_slow_queries=/var/log/mysql/mysql-slow.log'

Und die Installation endet schließlich erfolgreich.


Vielen Dank, genau das war es, was mich daran hinderte, ein Upgrade von Jessie auf Stretch durchzuführen
— xXx

war auch ein Grund für mich.
— Константин Рекунов

2

Versuchen Sie, alle Dateien in / var / lib / mysql irgendwo zu sichern. Löschen Sie sie alle und führen Sie dann mysql_install_db aus.

Mein Problem bestand darin, mysqld zu entfernen, durch mariadb zu ersetzen und zu versuchen, die Datenbankdateien zu behalten. Alle anderen Methoden sind für mich fehlgeschlagen.


1

Ihr System hat Probleme beim Ausführen des Skripts (nach) configure des Pakets mariadb-server-10.1.

Versuchen Sie zunächst, den apt-Cache mit zu reinigen apt-get cleanund das Paket neu zu installieren (bitte beachten Sie, dass apt-get autocleander Cache nur teilweise bereinigt wird).

Wenn dies fehlschlägt, mussten Sie den spezifischen Fehler verwenden dpkg -i mariadb-server-10.1und / oder dpkg-reconfigure mariadb-server-10.1genauer untersuchen.


1
sudo shutdown -r now

Ich weiß, es klingt verrückt, dass ein Neustart des Computers das Problem unter Linux gelöst hat, aber ich habe es doppelt überprüft. Ich arbeite jedoch in meiner Vagrant-Maschine und bin mir für Digital Ocean nicht sicher.

System:

  • Debian 7,
  • MySQL von Dotdeb mit einer funktionierenden Datenbank installiert,
  • aktualisierte MariaDB-Quellen und Schlüssel hinzugefügt,
  • Installieren Sie mariadb-server-10.1, das mit demselben Fehler endete.

Nach dem Neustart funktionierte alles, einschließlich der DB, die jetzt von MariaDB bereitgestellt wird.

Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.