Der SQL Server-Expressdienst wird nicht gestartet [geschlossen]


8

Ich habe gestern mein erstes VPS gekauft und Microsoft SQL Server 2012 Express darauf installiert .

Dann habe ich mein VPS neu gestartet. Der SQL Server-Dienst wurde jedoch nicht gestartet. Ich habe versucht, es manuell zu starten, aber es kann nicht gestartet werden:

Der SQL Server-Dienst wird nicht gestartet

Was ist das Problem? Wie man es löst?

PS: Dies ist meine erste Serververwaltung, und ich bin ein Neuling. Wenn Sie weitere Details dazu benötigen, hinterlassen Sie bitte einen Kommentar. Ich werde die Frage aktualisieren.

Update 1: Dies sind einige Protokolldetails aus der Ereignisanzeige, von denen ich dachte, dass sie für dieses Problem nützlich sein könnten:

FCB :: Öffnen fehlgeschlagen: Datei e: \ sql11_main_t.obj.x86release \ sql \ mkmastr \ database \ objfre \ i386 \ MSDBData.mdf für Dateinummer 1 konnte nicht geöffnet werden. Betriebssystemfehler: 3 (Das System kann den angegebenen Pfad nicht finden. ).

Die Build-Version der Ressourcendatenbank ist 11.00.3000. Dies ist nur eine Informationsnachricht. Es ist keine Benutzeraktion erforderlich.

FileMgr :: StartLogFiles: Betriebssystemfehler 2 (Das System kann die angegebene Datei nicht finden.) Ist beim Erstellen oder Öffnen der Datei 'e: \ sql11_main_t.obj.x86release \ sql \ mkmastr \ database \ objfre \ i386 \ MSDBLog.ldf' aufgetreten. Diagnostizieren und korrigieren Sie den Betriebssystemfehler und wiederholen Sie den Vorgang.

Datenbank 'Modell' starten.

FCB :: Öffnen fehlgeschlagen: Datei e: \ sql11_main_t.obj.x86release \ sql \ mkmastr \ database \ objfre \ i386 \ model.mdf für Dateinummer 1 konnte nicht geöffnet werden. Betriebssystemfehler: 3 (Das System kann den angegebenen Pfad nicht finden. ).

FileMgr :: StartLogFiles: Betriebssystemfehler 2 (Das System kann die angegebene Datei nicht finden.) Trat beim Erstellen oder Öffnen der Datei 'e: \ sql11_main_t.obj.x86release \ sql \ mkmastr \ database \ objfre \ i386 \ modellog.ldf' auf. Diagnostizieren und korrigieren Sie den Betriebssystemfehler und wiederholen Sie den Vorgang.

Ich bin verwirrt über diese e:\s, mein VPS hat nur ein Laufwerk C: \, also was ist e: \?


Schauen Sie sich die Protokolle an, wie in der Fehlermeldung angegeben. Gehen Sie zur Ereignisanzeige und nehmen Sie sie von dort.
— Sc0rian

@ Sc0rian Frage aktualisiert.
— Mahdi Ghiasi

Antworten:


15

Es gibt ein paar Themen auf, aber jemand gepostet eine gute Umgehung hier

NET START MSSQL$SQLEXPRESS /f /T3608

SQLCMD -S .\SQLEXPRESS

1>SELECT name, physical_name, state_desc FROM sys.master_files ORDER BY database_id;

Now notice those wrong file names; and run following commands ...

Note: you need to change the file name location ..

1>ALTER DATABASE model MODIFY FILE ( NAME = modeldev, FILENAME = 'c:\model.mdf');
2>ALTER DATABASE model MODIFY FILE ( NAME = modellog, FILENAME = 'c:\modellog.ldf');
3> go

ALTER DATABASE msdb MODIFY FILE ( NAME = MSDBData, FILENAME = 'c:\MSDBData.mdf');
ALTER DATABASE msdb MODIFY FILE ( NAME = MSDBLog, FILENAME = 'c:\MSDBLog.ldf');

ALTER DATABASE tempdb MODIFY FILE ( NAME = tempdev, FILENAME = 'c:\temp.mdf');
ALTER DATABASE tempdb MODIFY FILE ( NAME = templog, FILENAME = 'c:\temp.ldf');

go

exit;

NET STOP MSSQL$SQLEXPRESS 

Nachdem diese Befehle ausgeführt wird , nun bin immer ich diese Fehler (in der Ereignisanzeige): Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file 'c:\modellog.ldf'. Diagnose and correct the operating system error, and retry the operation.Wie schaffen diejenigen *.mdf, *.ldfDateien?
— Mahdi Ghiasi

Es waren model, modellog, MSDBData and MSDBLogDateien in C:\Program Files\Microsoft SQL Server\MSSQL11.SQLEXPRESS\MSSQL\DATA. Jetzt ist das Problem gelöst. Vielen Dank!
— Mahdi Ghiasi

Denken Sie daran, "Go" in der zweiten Zeile nach der ersten Abfrage einzugeben, um es auszuführen
— Iman

für mich aus irgendeinem Grund MSSQL12.SQLEXPRESS oder SQL 2014 LocalDB Express wurde anstelle des alten MSSQL11.SQLEXPRESS-Pfades ersetzt
— Iman
Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.