Kann ich eine Ausnahme machen, um_unknown_client_hostname abzulehnen?


11

Mein äußeres SMTP blockiert einige E-Mails mit dem Fehler 450 4.7.1 Client host rejected: cannot find your hostname, den wir zurückverfolgt haben reject_unknown_client_hostname. Der Hostname, in den die umgekehrte Adresse aufgelöst wird, hat selbst keinen DNS-Eintrag. Die Chancen, dies zu beheben, sind gering, aber wir müssen ihre E-Mail erhalten.

Können wir also eine Art Ausnahme konfigurieren, um diese Regel nur für sie zu umgehen?

Antworten:


14

Sie können einem bestimmten Client erlauben, Folgendes zu umgehen smtpd_client_restrictions:

smtpd_client_restrictions =
  check_client_access hash:/etc/postfix/client_access,
  reject_invalid_hostname

Dies würde zuerst die angegebene Aktion client_accessausführen. Wenn sie keiner der dort aufgeführten Regeln entspricht, lehnen Sie die Absender ab, die keine gültige Domäne haben.

Die Syntax in client_access lautet:

1.2.3.4    OK
bad.domain REJECT

Führen Sie nach dem Einrichten dieser Datei den folgenden Befehl aus, um die indizierte Version dieser Datei (db) zu generieren:

postmap /etc/postifx/client_access

Postfix neu laden und du solltest in Ordnung sein.

Weitere Dokumente zu Zugriffstabellen

Mehr zu smtpd_client_restrictions

BEARBEITEN : Wenn Sie dies aus irgendeinem Grund debuggen müssen, können Sie versuchen, das Debuggen in smtpd zu aktivieren, je nachdem, wer eine Verbindung zu Ihrem Dienst herstellt. Bearbeiten /etc/postfix/master.cf, suchen Sie den SMTPD-Dienst und fügen Sie eine Zeile wie die folgende hinzu:

smtp      inet  n       -       -       -       -       smtpd
       -o debug_peer_level=10 -o debug_peer_list=1.2.3.4

Das Debuggen wird nur für Peer 1.2.3.4 aktiviert . Dies sollte Ihnen eine Vorstellung davon geben, was passiert, wenn der Client 1.2.3.4 eine Verbindung zum SMTP-Dienst herstellt, um Ihnen E-Mails zu senden, indem Sie sich Ihr E-Mail-Protokoll ansehen.


Es funktioniert aus irgendeinem Grund nicht. Gibt es eine Möglichkeit, dies zu debuggen?
— Daniel C. Sobral

Überprüfen Sie die Antwort. Ich habe einige Informationen zum Debuggen des Szenarios nur für den Peer bearbeitet und eingefügt, der Sie beunruhigt.
— Torian

Danke, aber ich glaube, ich weiß, was das Problem ist ... Es sind nicht die Absenderregeln, die die E-Mail ablehnen, sondern die Clientregeln - also habe ich Änderungen am falschen Ort vorgenommen. Ich richte gerade die Konfiguration für den Client ein (check_client_access in smtpd_client_restrictions), und wenn alles gut geht, werde ich hier eine Notiz posten. Ich werde darum bitten, dass der Text korrigiert wird, bevor ich die Antwort akzeptiere. :-) Auf jeden Fall danke, dass du mich in die richtige Richtung gebracht hast.
— Daniel C. Sobral

In der Tat haben Sie Recht. Das Problem, dass der Client ohne umgekehrten DNS-Datensatz und nicht der Empfänger (oder von), an den er sendet, durch smtpd_client_restrictions gelöst wird. Die Art und Weise, wie Sie dies lösen, ist ähnlich. Ich werde die Antwort korrigieren. Gern geschehen und vielen Dank, dass Sie auf den Fehler hingewiesen haben.
— Torian

Ich habe anscheinend nicht genügend Punkte auf dieser Stapelplattform, um diesen hilfreichen Beitrag zu bearbeiten: Es gibt einen kleinen Tippfehler "postifx", der leicht übersehen wird.
— BurninLeo
Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.