So montieren Sie Time Capsule von Raspberry Pi


12

In meinem Heimnetzwerk befindet sich eine Time Capsule mit 2 TB (IP 192.168.0.1). Wie kann ich die Time Capsule-Festplatte von meinem Raspberry Pi aus nach einem Neustart automatisch laden?

Antworten:


14

Lege es in fstab.

sudo su
mkdir /mnt/timecapsule
echo "//timeCapsuleIp/Data /mnt/timecapsule cifs user=timecapsuleUsername,pass=timecapsuleUserPassword,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab

Erforderliches cifs-utilsPaket sollte bereits auf Raspbian bereitgestellt werden.

Natürlich ändern Sie timecapsuleUsername und timecapsuleUserPassword. Die uid = 1000 setzt den Eigentümer der gemounteten Dateien auf den Benutzer pi. Wenn Sie einen anderen Benutzer verwenden, überprüfen Sie dessen UID mit id -u username. Überprüfen Sie, ob der Ordner "Data" für Sie geeignet ist - listen Sie die Ressourcen mit einem Befehl auf smbclient -Uusername -I ip-address -L.


Ich bekomme diese Fehlermeldung , wenn zu montieren versuchen: mount error(115): Operation now in progress. Ich kann jedoch mit smbclient auf die Freigabe zugreifen. Irgendwelche Ideen?
— Arne

Verstanden: Ich habe es zuerst mit dem .localNamen anstatt der IP versucht , scheint aber nicht zuverlässig zu funktionieren. Zweitens musste ich sec=ntlmdie Optionen ergänzen . Jetzt funktioniert es!
— Arne

Wenn die Option Disks Secure SharedDisks With a disk passwordausgewählt ist, wird user=param ignoriert, unabhängig davon, auf was es eingestellt ist
— Hengjie

Dies wurde gerade auf einer Time Capsule getestet, auf der die neueste (7.6.7) Firmware auf einem Pi mit OSMC ausgeführt wird. Der Schlüssel ist sec=ntlmund ich kann bestätigen, dass dies mit Festplatten funktioniert, die mit einem Gerätekennwort sowie einem Festplattenkennwort gesichert sind.
— Gary Gale

5

Ich habe sec = ntlm zu den Optionen hinzugefügt, der vollständige Befehl lautet:

sudo su
mkdir /mnt/timecapsule
echo "//timeCapsuleIp/Data /mnt/timecapsule cifs user= timecapsuleUsername,pass= timecapsuleUserPassword,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab

Führen Sie dann diesen Befehl aus:

mount -a

Sie sollten keine Fehler erhalten.


4

Update für Benutzer von Raspberry Stretch v9. Beachten Sie die Addition von vers = 1.0

//IPofTimeCapsule/PathWithinYourTimeCapsule /mnt/TimeCapsule cifs username=insert,password=insert,rw,uid=1000,iocharset=utf8,sec=ntlm,vers=1.0 0 0

Was meinst du mit der Zeile beginnend mit //IPofTimeCapsule?
— Ingo

Entschuldigung, wenn ich nicht klar war, meinte ich die IP-Adresse von TimeCapsule. Die Zeile könnte beispielsweise lauten: //192.168.1.11/Data / mnt / TimeCapsule cifs Benutzername = bsmith, Kennwort = batman, rw, uid = 1000, iocharset = utf8, sec = ntlm, vers = 1.0 0 0
— ddavila

1

Wenn ich ein Festplattenkennwort für die Zeitkapsel verwende, funktioniert dies nur, wenn ich uid = 504 hinzufüge (dies ist die Benutzer-ID, die auf dem Macintosh hauptsächlich für die Zeitkapsel und nicht für die Himbeere verwendet wird). Wenn ich uid = 504 nicht angegeben habe, wurde "Bereitstellungsfehler (16): Gerät oder Ressource belegt" von der Zeitkapsel zurückgegeben.

Durch die Nutzung unserer Website bestätigen Sie, dass Sie unsere Cookie-Richtlinie und Datenschutzrichtlinie gelesen und verstanden haben.
Licensed under cc by-sa 3.0 with attribution required.